WarcraftReamls.com
  FAQFAQ    SearchSearch    MemberlistMemberlist    UsergroupsUsergroups   RegisterRegister 
  ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in 
Uhh...

 
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> WarcraftRealms.com Bugs
View previous topic :: View next topic  
Author Message
Balgair
Araiceil


Joined: 30 Sep 2005
Posts: 1543
Location: UK
WR Updates: 11,295,781
Balgair WR Profile

PostPosted: Wed Apr 08, 2009 7:31 pm    Post subject: Uhh... Reply with quote

Quote:
<Uploading>




Looking for file
IP: X.X.X.X<br>
United Kingdom<br>
X.X.X.X - gb -
File appears to be valid, checking your version number.
Checking your file
Found CensusPlus Database
Found CensusPlus Info Data
Found Version Number => Version: 4.2.2 <Found> Locale: EU <=
Attempting to make entry

Getting User/pass
Username : Balgair<Error> Unable to query : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3 on line: 285 of /home/wrlogin/public_html/uniupload.php


Not sure if this is connected to me having already done an upload in the last 15 mins (uploaded from wrong account and trying to overwrite it) but that's what I got just now on uniuploader anyway Wink I'll watch the server response next time I do any uploads and see if it happens again, might be a one-off but thought I'd give a heads-up anyway!
_________________
EU-Draenor:
-- Sagart - Tairbh - Buinne - Balgair - Naomh - Eilnich - Ruire - Dubh - Laidir --
Back to top
View user's profile Send private message
Kosh



Joined: 01 Jul 2007
Posts: 84
Location: Somewhere on or near Earth
WR Updates: 1,210,548
Kosh WR Profile

PostPosted: Thu Apr 09, 2009 2:47 am    Post subject: Reply with quote

Yea, it seems that several people (including me) have occasionally seen that error. From the context and verbiage, I suspect that what is actually happening is that an error handler is assuming that a MySQL error is a SQL syntax error, where in this case, it is probably another database error (my guess would be a table or other resource lock that is blocking the query).

At least for me, retrying the upload a little later is successful. so just try again in a couple of minutes.


Rollie, this brings up a question I keep meaning to ask.... I can't think of any case where random Joe-user crediting my account for an upload would be detrimental to me, so I was wondering why the password is needed for the upload script?
Back to top
View user's profile Send private message
Rollie
Site Admin


Joined: 28 Nov 2004
Posts: 5374
Location: Austin, TX
WR Updates: 480,131
Rollie WR Profile

PostPosted: Fri Apr 10, 2009 12:45 am    Post subject: Reply with quote

You know, that makes a lot of sense. There really is no reason that you would have to be authenticated to do an upload.

@Bal -

Yes, if you see that occur again, please let me know as it is not something I would expect to see.
Back to top
View user's profile Send private message Visit poster's website
Kosh



Joined: 01 Jul 2007
Posts: 84
Location: Somewhere on or near Earth
WR Updates: 1,210,548
Kosh WR Profile

PostPosted: Fri Apr 10, 2009 7:34 pm    Post subject: Reply with quote

Rollie, if you have sufficiently detailed logging, check for a couple of errored-out submissions from me before my successful submission at 18:35:07 today. My script doesn't currently output a timestamp on errors, so can't be more exact than a couple of minutes before the successful try. They would all be from the same IP address. The error text is always the same (script & line number, but no SQL in the quotes).

As noted, I waited a couple of minutes after the errors, and the submission succeeded.
Back to top
View user's profile Send private message
Kosh



Joined: 01 Jul 2007
Posts: 84
Location: Somewhere on or near Earth
WR Updates: 1,210,548
Kosh WR Profile

PostPosted: Thu Apr 16, 2009 4:03 am    Post subject: Reply with quote

I have been paying closer attention to when I have been receiving a MySQL error during uploads. My sample size is small, so this might just be an anomaly, but in each such case, the failed upload was attempted "soon" (but over 15 minutes) after the previous upload.

For example, after my successful upload at 04-16-2009 03:01:22, I attempted to upload three times starting at about 03:18, which all failed. The fourth attempt was successful, at 03:19:30, ending 18:08 after the previous successful upload.

Not knowing your queries & DML, I don't know if "time since last seen" could affect anything relevant, but if this gives you any possibilities to look into, great. Otherwise, I will keep looking for patterns; after all, it is a small sample size. Smile
Back to top
View user's profile Send private message
Rollie
Site Admin


Joined: 28 Nov 2004
Posts: 5374
Location: Austin, TX
WR Updates: 480,131
Rollie WR Profile

PostPosted: Fri Apr 17, 2009 8:11 am    Post subject: Reply with quote

It is very possible I have something jacked in the subsequent uploads for uniuploader.

Thank you for your trials and info!
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> WarcraftRealms.com Bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
WarcraftRealms.com  


Powered by phpBB © 2001, 2005 phpBB Group