WarcraftReamls.com
  FAQFAQ    SearchSearch    MemberlistMemberlist    UsergroupsUsergroups   RegisterRegister 
  ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in 
CensusPlus-30300-4.2.2 (3.3.0) - Lua Error

 
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> CensusPlus UI Mod Bugs
View previous topic :: View next topic  
Author Message
Aquatic Elf



Joined: 31 Jan 2007
Posts: 7

WR Updates: 943,729
Aquatic Elf WR Profile

PostPosted: Fri Feb 05, 2010 5:13 pm    Post subject: CensusPlus-30300-4.2.2 (3.3.0) - Lua Error Reply with quote

I just updated my CensusPlus to the new version (CensusPlus-30300-4.2.2 (3.3.0)) and I'm getting a Lua Error:

Code:
Message: Interface\AddOns\CensusPlus\CensusPlus.lua:1352: attempt to index global 'LibStub' (a nil value)
Time: 02/05/10 17:57:07
Count: 3
Stack: Interface\AddOns\CensusPlus\CensusPlus.lua:1352: in function `CensusPlus_StartCensus'
Interface\AddOns\CensusPlus\CensusPlus.lua:1170: in function `func'
Interface\FrameXML\UIDropDownMenu.lua:575: in function `UIDropDownMenuButton_OnClick'
[string "*:OnClick"]:1: in function <string>

Locals: counter = 0
job = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
hour = 14
minute = 56
(*temporary) = nil
(*temporary) = nil
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = nil
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = <function> defined @Interface\AddOns\CensusPlus\CensusPlus.lua:1516
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = "attempt to index global 'LibStub' (a nil value)"
g_CurrentlyInBG = false
g_LastCensusRun = 1265410617
g_CurrentlyInBG_Msg = false
g_CensusPlus_StartTime = 1265410627
g_NumNewCharacters = 0
g_NumUpdatedCharacters = 0
g_JobQueue = <table> {
 1 = <table> {
 }
 2 = <table> {
 }
 3 = <table> {
 }
 4 = <table> {
 }
 5 = <table> {
 }
 6 = <table> {
 }
 7 = <table> {
 }
 8 = <table> {
 }
 9 = <table> {
 }
}
g_TempCount = <table> {
}
g_TempZoneCount = <table> {
}
InsertJobIntoQueue = <function> defined @Interface\AddOns\CensusPlus\CensusPlus.lua:373
g_WaitingForWhoUpdate = false
g_TakeHour = 14
g_ResetHour = true
wholib = nil


The error comes up either when I manually start census, or when it automatically begins scanning by itself.

I downloaded the addon through:
http://wow.curse.com/downloads/wow-addons/details/census-plus.aspx

I did not delete any of my WTF files before updating the addon.
Back to top
View user's profile Send private message
Aquatic Elf



Joined: 31 Jan 2007
Posts: 7

WR Updates: 943,729
Aquatic Elf WR Profile

PostPosted: Sat Feb 06, 2010 3:10 am    Post subject: Reply with quote

I'd like to add that only a few of my characters were experiencing this error.

It does not occur on every character.
Back to top
View user's profile Send private message
Rollie
Site Admin


Joined: 28 Nov 2004
Posts: 5374
Location: Austin, TX
WR Updates: 480,131
Rollie WR Profile

PostPosted: Sat Feb 06, 2010 10:38 am    Post subject: Reply with quote

hrm... thanks for the report
Back to top
View user's profile Send private message Visit poster's website
Hybuir
Gear Dependent Squirrel
Gear Dependent Squirrel


Joined: 06 Sep 2005
Posts: 1532
Location: Austin, TX
WR Updates: 2,503,757
Hybuir WR Profile

PostPosted: Sun Feb 07, 2010 11:33 pm    Post subject: Reply with quote

report #2, going in with only C+ and no other addons :-/
Code:
Message: Interface\AddOns\CensusPlus\CensusPlus.lua:1352: attempt to index global 'LibStub' (a nil value)
Time: 02/07/10 23:32:39
Count: 1
Stack: Interface\AddOns\CensusPlus\CensusPlus.lua:1352: in function `CensusPlus_StartCensus'
Interface\AddOns\CensusPlus\CensusPlus.lua:1170: in function `CensusPlus_Take_OnClick'
Interface\AddOns\CensusPlus\CensusPlus.lua:1959: in function <Interface>

Locals: counter = 0
job = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
hour = 21
minute = 32
(*temporary) = nil
(*temporary) = nil
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = nil
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = <function> defined @Interface\AddOns\CensusPlus\CensusPlus.lua:1516
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = "attempt to index global 'LibStub' (a nil value)"
g_CurrentlyInBG = false
g_LastCensusRun = 1265605656
g_CurrentlyInBG_Msg = false
g_CensusPlus_StartTime = 1265607159
g_NumNewCharacters = 0
g_NumUpdatedCharacters = 0
g_JobQueue = <table> {
 1 = <table> {
 }
 2 = <table> {
 }
 3 = <table> {
 }
 4 = <table> {
 }
 5 = <table> {
 }
 6 = <table> {
 }
 7 = <table> {
 }
 8 = <table> {
 }
 9 = <table> {
 }
}
g_TempCount = <table> {
}
g_TempZoneCount = <table> {
}
InsertJobIntoQueue = <function> defined @Interface\AddOns\CensusPlus\CensusPlus.lua:373
g_WaitingForWhoUpdate = false
g_TakeHour = 21
g_ResetHour = true
wholib = nil

_________________

Back to top
View user's profile Send private message Visit poster's website AIM Address
Rollie
Site Admin


Joined: 28 Nov 2004
Posts: 5374
Location: Austin, TX
WR Updates: 480,131
Rollie WR Profile

PostPosted: Tue Mar 16, 2010 9:26 am    Post subject: Reply with quote

Yeah, this would be due to my attempt to support WhoLib, need to add in additional checks it seems.
Back to top
View user's profile Send private message Visit poster's website
SannaSK



Joined: 07 Sep 2005
Posts: 69

WR Updates: 403,736
SannaSK WR Profile

PostPosted: Fri Mar 26, 2010 2:52 pm    Post subject: Reply with quote

Recently (ie, today X D) started running CP again.
I'm getting, I guess, the same/ a similar error... going around to servers with low reportings and making a lvl 1, logging in with no other addons running. I have a general macro that is only /censusplus take, and when i press that, I get this:

Code:
Message: Interface\AddOns\CensusPlus\CensusPlus.lua:1352: attempt to index global 'LibStub' (a nil value)
Time: 03/26/10 15:47:56
Count: 1
Stack: Interface\AddOns\CensusPlus\CensusPlus.lua:1352: in function `CensusPlus_StartCensus'
Interface\AddOns\CensusPlus\CensusPlus.lua:1170: in function `CensusPlus_Take_OnClick'
Interface\AddOns\CensusPlus\CensusPlus.lua:1004: in function `value'
Interface\FrameXML\ChatFrame.lua:3577: in function `ChatEdit_ParseText'
Interface\FrameXML\ChatFrame.lua:3222: in function `ChatEdit_SendText'
Interface\FrameXML\ChatFrame.lua:2308: in function <Interface>
[C]: in function `UseAction'
Interface\FrameXML\SecureTemplates.lua:310: in function `handler'
Interface\FrameXML\SecureTemplates.lua:529: in function <Interface>

Locals: counter = 0
job = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
hour = 16
minute = 47
(*temporary) = nil
(*temporary) = nil
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = nil
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = <function> defined @Interface\AddOns\CensusPlus\CensusPlus.lua:1516
(*temporary) = <table> {
 m_MinLevel = 80
 m_MaxLevel = 80
}
(*temporary) = "attempt to index global 'LibStub' (a nil value)"
g_CurrentlyInBG = false
g_LastCensusRun = 1269634950
g_CurrentlyInBG_Msg = false
g_CensusPlus_StartTime = 1269636476
g_NumNewCharacters = 0
g_NumUpdatedCharacters = 0
g_JobQueue = <table> {
 1 = <table> {
 }
 2 = <table> {
 }
 3 = <table> {
 }
 4 = <table> {
 }
 5 = <table> {
 }
 6 = <table> {
 }
 7 = <table> {
 }
 8 = <table> {
 }
 9 = <table> {
 }
}
g_TempCount = <table> {
}
g_TempZoneCount = <table> {
}
InsertJobIntoQueue = <function> defined @Interface\AddOns\CensusPlus\CensusPlus.lua:373
g_WaitingForWhoUpdate = false
g_TakeHour = 16
g_ResetHour = true
wholib = nil


it takes the census just fine, so i don't mind ignoring a lua as long as it's not corrupting the data or anything.

edit: same error (i'm guessing) when i right-click the minimap icon.
Back to top
View user's profile Send private message
Leonaitis



Joined: 15 Aug 2005
Posts: 14
Location: FL, USA
WR Updates: 342,519
Leonaitis WR Profile

PostPosted: Thu Apr 08, 2010 10:37 am    Post subject: Reply with quote

Same for me. I just did a clean WOW install on a new machine and the only add on is CP.
Takes the census fine though.
Sad
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> CensusPlus UI Mod Bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
WarcraftRealms.com  


Powered by phpBB © 2001, 2005 phpBB Group