Page 1 of 1

Prune command not working?

Posted: Wed Sep 11, 2013 6:26 am
by SannaSK
Ok here's a really strange... bug?

I have a macro that I hit that looks like this
/censusplus prune 3
/censusplus take

this helps me refrain from uploading too much data multiple times, forcing the server to crunch unnecessarily-duplicated data.

I noticed yesterday that I wasn't seeing the text about 'Pruning all characters over 3 days old' or whatever. So I tried just now to send the prune command manually. I opened a chat-edit window, typed in the command... and I could not even hit enter to send the command. I've never come across that before, when I wasn't able to even send a command. I did this on a character with no other addons enabled but CensusPlus and ACP.

Is this broken? Intentionally broken? Something you've not seen before either? Meep?

Posted: Wed Sep 11, 2013 6:42 am
by SannaSK
well no sooner do i speak, and then I click my macro and get this error:
(this time I was on a character with many addons enabled, as you will see in the Giant List o'Addons) (also i changed an angled-bracket pair around 'table' to be [ ] square brackets so the forum wouldn't eat the text) :

Date: 2013-09-11 08:39:38
ID: 2
Error occured in: Global
Count: 1
Message: ..\AddOns\CensusPlus\CensusPlus.lua line 3721:
field 'day' missing in date table
Debug:
[C]: time()
CensusPlus\CensusPlus.lua:3721: CensusPlus_PruneData()
CensusPlus\CensusPlus.lua:896: ?()
..\FrameXML\ChatFrame.lua:4316: ChatEdit_ParseText()
..\FrameXML\ChatFrame.lua:3962: ChatEdit_SendText()
..\FrameXML\ChatFrame.lua:2623:
..\FrameXML\ChatFrame.lua:2616
[C]: UseAction()
..\FrameXML\SecureTemplates.lua:348: handler()
..\FrameXML\SecureTemplates.lua:633:
..\FrameXML\SecureTemplates.lua:581
[C]: ?
..\FrameXML\SecureHandlers.lua:264:
..\FrameXML\SecureHandlers.lua:261
[C]: ?
..\FrameXML\SecureHandlers.lua:294:
..\FrameXML\SecureHandlers.lua:277
(tail call): ?
Locals:
(*temporary) = [table] {
hour = 0
day = "ard"
year = "Bron"
month = "eb"
}
(*temporary) = "ard"

AddOns:
Swatter, v5.17.5413 (NeedyNoddy)
WowheadLooter, v50013
ACP, v3.4.4
Altoholic, v5.3.001
AraBrokerReputations, vr14
AutoBar, vv5.2.0.0
Babylonian, v5.1.DEV.332(/embedded)
Bagnon, v5.4.0
Bartender4, v4.5.10
BeanCounter, v5.17.5413 (NeedyNoddy)
BrokerAllXP, v1.6.6-release
BrokerCurrency, v5.3.0-1.3.1
BrokerXPBarGuild, v1.4 r011
CensusPlus, v6.1.0
Chatter, v1.4.4
ChocolateBar, vv2.4.1
CompanionClone, v1.7.1
Configator, v5.1.DEV.344(/embedded)
CrapAway, v
DataStore, v5.3.001
DataStoreAchievements, v5.3.001
DataStoreAgenda, v5.3.001
DataStoreAuctions, v5.3.001
DataStoreCharacters, v5.3.001
DataStoreContainers, v5.3.001
DataStoreCrafts, v5.3.001
DataStoreCurrencies, v5.3.001
DataStoreInventory, v5.3.001
DataStoreMails, v5.3.001
DataStorePets, v5.3.001
DataStoreQuests, v5.3.001
DataStoreReputations, v5.3.001
DataStoreSpells, v5.3.001
DataStoreStats, v5.3.001
DataStoreTalents, v5.3.001
DBMCore, v
DebugLib, v5.1.DEV.337(/embedded)
DropTheCheapestThing, vv3.6.4
ElkBuffBars, v2.3.2-172
EmoteLDB, v50400-1.0
EnergyWatch, v5.3.0
GnomishVendorShrinker, v5.0.1.15
InFlightLoad, v5.3.001
Informant, v5.17.5413 (NeedyNoddy)
LibExtraTip, v5.12.DEV.350(/embedded)
Livestock, v1.9.6
LuckyCharms2, vr41
Mapster, v1.5.4
Multishot, v3.1.1
PitBull4, vv4.0.0-beta46
PitBull4Aggro, vv4.0.0-beta46
PitBull4AltPowerBar, vv4.0.0-beta46
PitBull4Aura, vv4.0.0-beta46
PitBull4Background, vv4.0.0-beta46
PitBull4BattlePet, vv4.0.0-beta46
PitBull4BlankSpace, vv4.0.0-beta46
PitBull4Border, vv4.0.0-beta46
PitBull4BurningEmbers, vv4.0.0-beta46
PitBull4CastBar, vv4.0.0-beta46
PitBull4CastBarLatency, vv4.0.0-beta46
PitBull4CombatFader, vv4.0.0-beta46
PitBull4CombatIcon, vv4.0.0-beta46
PitBull4CombatText, vv4.0.0-beta46
PitBull4ComboPoints, vv4.0.0-beta46
PitBull4DemonicFury, vv4.0.0-beta46
PitBull4HealthBar, vv4.0.0-beta46
PitBull4HideBlizzard, vv4.0.0-beta46
PitBull4Highlight, vv4.0.0-beta46
PitBull4HostilityFader, vv4.0.0-beta46
PitBull4LeaderIcon, vv4.0.0-beta46
PitBull4LuaTexts, vv4.0.0-beta46
PitBull4MasterLooterIcon, vv4.0.0-beta46
PitBull4PhaseIcon, vv4.0.0-beta46
PitBull4PowerBar, vv4.0.0-beta46
PitBull4PvPIcon, vv4.0.0-beta46
PitBull4QuestIcon, vv4.0.0-beta46
PitBull4RaidTargetIcon, vv4.0.0-beta46
PitBull4RangeFader, vv4.0.0-beta46
PitBull4ReadyCheckIcon, vv4.0.0-beta46
PitBull4RestIcon, vv4.0.0-beta46
PitBull4RoleIcon, vv4.0.0-beta46
PitBull4SoulShards, vv4.0.0-beta46
PitBull4ThreatBar, vv4.0.0-beta46
Postal, v3.5.1
Quartz, v3.1.3
QuestGuruTracker, v1.5.15-50300
SharedMedia, v3.0.5-183
shPerformance, v
Stubby, v5.17.5413 (NeedyNoddy)
teksLoot, v5.0.1.11
TidyPlates, v6.12.1
TidyPlatesThreatPlates, v6.008
TidyPlatesHub, v
TidyPlatesWidgets, v
TipHelper, v5.12.DEV.351(/embedded)
TipTac, v13.05.22
TipTacItemRef, v13.05.22
TomTom, vv50300-1.0.0
Volumizer, v5.3.0-2.2
BlizRuntimeLib_enUS v5.4.0.50400 <us>
(ck=bc3)

Posted: Wed Sep 11, 2013 9:36 am
by bringoutyourdead
another good catch... your now comparing number of days vs. guild realm.. sigh..
another patch to come...

I'm waiting on another possible problem area... something that only impacts EU players..
thanks to someones, in (I think) Blizzard EU, moment of insanity.

Posted: Wed Sep 11, 2013 12:46 pm
by bringoutyourdead
As I thought/feared to be the case... Live EU testing as proven the existence of two more bugs... things that couldn't be tested for in PTR.

I hope to have a patch update later today for all three...
if anyone sees anything else that is odd.. please do as SannaSK did...

Tell me what you are doing.. commands issued etc.
and if possible the error output...
or if not a description of what you saw that you know/believe to be wrong.

Posted: Wed Sep 11, 2013 2:17 pm
by bringoutyourdead
Balgair has been given a update to try for EU testing...
it fixes the mismatch between realm names in the EU region...
this was causing the problems of new xx updated 0
this also fixes the character realm and guild realm region matching for the website...
most of which already worked... but if you happened to run the Portuguese realm or mouse over/target a character from that realm the data probably would E out on upload.

I'm not seeing any issues running the fix on US data center realms.. but then I didn't expect to all the coding was in the areas the handled the duplicate realm names between US and EU... and the stupid naming of the Portuguese realm... the person implementing that name should be fired... or flogged (wet noodle optional)

Posted: Wed Sep 11, 2013 3:09 pm
by Balgair
Update appears to work ok; I've sent my data to BOYD and if he agrees I haven't missed anything stupid, that's hopefully it. Seems to behave how I'd expect it to anyway.

The Portuguese realm didn't make data E out btw, I didn't purge before uploading and it still processed; think the database just drops anything from realms it doesn't recognise ;)